Расширенная конфигурация и дополнительные возможности

1. Вывод NMEA данных одновременно в несколько СОМ портов
2. Частота считывания информации с GNSS приёмника
3. Передача NMEA данных по протоколу UDP на любой адрес:порт
4. Расположения файлов с информацией о пройдённом маршруте (KML, GPX)
5. Копирование информации о текущем местоположении в буфер обмена
6. Вывод «сырых» данных NMEA в лог файл
7. Мониторинг состояния навигационной программы

1. Вывод NMEA данных одновременно в несколько СОМ портов

Программа обеспечивает вывод NMEA данных одновременно до четырёх СОМ портов.

Соответствующая конфигурация и параметры "дополнительных" СОМ портов устанавливаются в конфигурационном в ini файле:

Для активации данного режима необходимо секциях [Port #2], [Port #3] и [Port #4] параметр Number установить в ненулевое значение, соответствующее номеру СОМ порта.

Например:

[Port #2]
Number=5
BaudRate=57600
AutoStart=0

где:

Number - номер COM порта куда отсылать данные (порт можно выбрать и вручную в GUI программы)
BaudRate - скорость передачи данных через COM порт
AutoStart - 1 =>открытие указанного выше COM порта автоматически при старте программы.

При работе программы "дополнительные" СОМ порты можно показать через меню:

Options -> Output -> Show extra COM ports

2. Частота считывания информации с GNSS приёмника

Возможно задать произвольную частоту получения информации от GNSS приёмника.

Соответствующая конфигурация устанавливаются в конфигурационном в ini файле:

[GNSS]
ReportInterval=1000

где:

ReportInterval – частота в миллисекундах.

Установка значения ReportInterval меньше, чем приёмник может выдать (Minium Report Interval - его можно посмотреть в информации о сенсоре - чаще всего это 1000 или 500 миллисекунд) ничего не даст, зато можно установить большее значение.

Если цель получения данных не является навигацией, то установив, например, значение 5000, можно сохранять данные в трек каждые 5 секунд.

3. Передача NMEA данных по протоколу UDP на любой адрес:порт

В качестве получателя может быть как любой сетевой клиент, так и виртуальный порт Тиббо, соответствующим образом сконфигурированный.
В итоге имеем не пару виртуальных портов, а всего один (только со стороны навигационной программы).

По умолчанию в программе вывод в UDP отключён.

Для вывода данных по UDP (до четырёх получателей) нужно в конфигурационном файле указать:

[UDP #1]
IP=127.0.0.1
Port=1015

где:

IP - адрес получателя (если на локальном компе, то естественно оставляем 127.0.0.1,
тем не менее может быть любой адрес в локальной сети или интернете).

Port - соответствующий UDP порт на стороне получателя.

Соответственно также сделать, если необходимо, настройки для [UDP #2], [UDP #3].и [UDP #4].

4. Расположения файлов с информацией о пройдённом маршруте (KML, GPX)

Информация о пройдённом маршруте может быть выведена в файлы формата KML и GPX. Соответствующая опция активируется через настройки, а также можно включить через меню: Options -> Output -> KML file

По умолчанию KML файл создаётся в папке с программой.

Однако можно задать папку для сохранения KML файлов, для этого необходимо соответствующим образом изменить параметр Directory в ini файле:

[KML]
Directory=C:\Мои маршруты

где:

Directory – Папка для сохранения отчётов.

5. Копирование информации о текущем местоположении в буфер обмена

В самой программе копирование производится комбинацией Ctrl+Alt+C или через меню: File->Save To Clipboard.

Есть возможность назначить свою комбинацию клавиш, как дополнение Ctrl+Alt+C, в конфигурационном в ini файле нужно задать соответствующий параметр Shortcut:

[Clipboard]
Shortcut=Ctrl+Alt+G

(в параметре Shortcut можно использовать идентификаторы такие как Ctrl, Alt и Shift)

Данные в буфер обмена копируются в фиксированном текстовом формате, в виде:

Timestamp: 0000-00-00T00:00:00Z
Latitude: 0.0000000000
Longitude: 0.0000000000
Altitude, sea level: 0.0000000000
Altitude, ellipsoid: 0.0000000000
Speed, knots: 0.0000000000
Speed, km/h: 0.0000000000
Direction: 0.0000000000

(естественно с реальными данными)

Тем не менее, можно указать и собственный формат вывода данных.
Для этого в конфигурационном в ini файле указываем путь к файлу с шаблоном:

[Clipboard]
Template=GnssDataInterface.xcl

В шаблоне возможно использовать следующие параметры:

$TimeStamp$ - TimeStamp
$LatitudeDegrees$ - Широта
$LongitudeDegrees$ - Долгота
$AltitudeSealevelMeters$ - Высота над уровнем моря
$AltitudeAntennaSealevelMeters$ - Высота антенны над уровнем моря
$AltitudeEllipsoidMeters$ - Высота над эллипсоидом WDS84
$SpeedKnots$ - Скорость в узлах
$SpeedKmph$ - Скорость в км/ч
$TrueHeadingDegrees$ - Направление движения
$NMEA$ - NMEA данные

Шаблон загружается в память при старте программы.

При сохранении в буфер обмена программа автоматически заменяет параметры $TimeStamp$, $LatitudeDegrees$ и т.д. ответствующими реальными значениями.

Есть возможность задать глобальный HotKey, который будет работать не зависимо, активно ли окно программы в данный момент или нет.

Для установки глобальный HotKey нужно задать соответствующий параметр HotKey в конфигурационном в ini файле:

[Clipboard]
HotKey=0x03,0x47

Формат параметра HotKey:

HotKey=Modifier,KeyCode

где:

Modifier - комбинация через "логическое или" любых вариантов из следующих значений:

Alt - 0x01
Ctrl - 0x02
Shift - 0x04
Win - 0x08

KeyCode - виртуальный код клавиши на клавиатуре.

Соответствующий список кодов можно найти тут: http://msdn.microsoft.com/en-us/library/windows/desktop/dd375731(v=vs.85).aspx

В указанном выше примере, HotKey=0x03,0x47 задаётся комбинация клавиш Ctrl+Alt+G

Ещё примеры:

HotKey=0x08,0x48 => Win+H HotKey=0x08,0x75 => Win+F6

Следует обратить внимание, что не все комбинации «горячих клавиш» могут быть использованы из-за ограничений со стороны операционной системы, а также данная комбинация «горячих клавиш» может быть уже использована в другом приложении.

6. Вывод «сырых» данных NMEA в лог файл

Для активизации данной возможности необходимо установить в единицу соответствующий параметр AutoStart в конфигурационном в ini файле:

[RAW]
AutoStart=1

Имя файла генерируется автоматически в формате YYYY-MM-DD HH.MM.SS.NMEA

где:

yyyy-mm-dd hh.mm.ss - дата и время начала записи в файл (дата и время активации интерфейса).

По умолчанию NMEA файл создаётся в папке с программой.

Есть возможность задать папку для сохранения NMEA лог файлов, для этого необходимо соответствующим образом изменить параметр Directory в ini файле:

[RAW]
Directory=C:\Мои маршруты

где:

Directory – Папка для сохранения лог файлов.

Для ограничения размеров лог файла возможно задать максимальное количество записей в файл:

[RAW]]
MaxRecords=1000

где:

MaxRecords – максимальное количество отсчётов данных.

Если параметр MaxRecords не задан или равняется нулю, то создаётся один файл

YYYY-MM-DD HH.MM.SS.NMEA и запись продолжается пока хватит места на диске.

Если же параметр MaxRecords задан, то при начале записи создаётся файл
YYYY-MM-DD HH.MM.SS 00000001.NMEA

Затем, после достижения максимального кол-ва записей (отсчётов с данными), создаются файлы

YYYY-MM-DD HH.MM.SS 00000002.NMEA
YYYY-MM-DD HH.MM.SS 00000003.NMEA

и так далее.

7. Мониторинг состояния навигационной программы

GNSS Data Interface отслеживает состояние навигационной программы. В случае завершения работы навигационной программы GNSS Data Interface также может автоматически завершить свою работу. Таким образом, можно использовать GNSS Data Interface как оболочку для автоматического запуска навигационной программы.

Для автоматического закрытия GNSS Data Interface необходимо установить параметр ShellMode=1 в разделе [Navigation] конфигурационного файла.

Например:

[Navigation]
AutoStart=0
Application=C:\iGo8\iGo.exe
ShellMode=1


Значение по умолчанию:

ShellMode=0

 

Copyright © 2007 www.black-it.eu All rights reserved.
Последнее изменение: 08.01.2019
www.000webhost.com