WhatsNew.txt

===============
Версия 1.1.0.36
===============

Новые возможности:
------------------

* Мониторинг состояния навигационной программы (завершение работы навигационной
программы)

* Автоматическое закрытие GNSS Data Interface в случае завершения работы
навигационной программы

Для автоматического закрытия GNSS Data Interface нужно установить параметр
ShellMode=1 в разделе [Navigation] конфигурационного файла.

Например:

[Navigation]
AutoStart=0
Application=C:\iGo8\iGo.exe
ShellMode=1

Значение по умолчанию ShellMode=0


===============
Версия 1.1.0.32
===============


Исправления:
------------

* Исправление незначительных ошибок


===============
Версия 1.1.0.31
===============


Исправления:
------------

* Исправление ошибки в эмуляции NMEA данных
(вместо координат в формате xxyy.000985 ранее емулировалось xxyy.985)


===============
Версия 1.1.0.30
===============


Исправления:
------------

* Исправление незначительных ошибок


===============
Версия 1.1.0.29
===============

Новые возможности:
------------------

* Автоматический запуск программы при старте операционной системы


* Звуковые эффекты


* Копирование информации о текущем местоположении в буфер обмена.

В самой программе копирование производится комбинацией Ctrl+Alt+C или через
меню: File->Save To Clipboard.

Данные в буфер обмена копируются в фиксированном текстовом формате.

Тем не менее, также можно указать и собственный формат вывода данных в буфер
обмена.

Для этого в конфигурационном в ini файле указываем путь к файлу с шаблоном:

[Clipboard]
Template=GnssDataInterface.xcl

В файле-шаблоне возможно использовать следующие параметры:

$TimeStamp$ - TimeStamp
$LatitudeDegrees$ - Широта
$LongitudeDegrees$ - Долгота
$AltitudeSealevelMeters$ - Высота над уровнем моря
$AltitudeAntennaSealevelMeters$ - Высота антенны над уровнем моря
$AltitudeEllipsoidMeters$ - Высота над эллипсоидом WDS84
$SpeedKnots$ - Скорость в узлах
$SpeedKmph$ - Скорость в км/ч
$TrueHeadingDegrees$ - Направление движения
$NMEA$ - NMEA данные



Есть возможность задать глобальный HotKey, который будет работать не зависимо,
активно ли окно программы в данный момент или нет.

Для установки глобальный HotKey нужно задать соответствующий параметр HotKey в
конфигурационном в ini файле:

[Clipboard]
HotKey=0x03,0x47

В указанном выше примере задаётся комбинация клавиш Ctrl+Alt+G

Ещё примеры:

HotKey=0x08,0x48 => win+H
HotKey=0x08,0x75 => Win+F6

Формат параметра HotKey:

HotKey=Modifier,KeyCode

где:

Modifier - комбинация через "логическое или" любых вариантов из следующих значений:

Alt - 0x01
Ctrl - 0x02
Shift - 0x04
Win - 0x08

KeyCode - виртуальный код клавиши на клавиатуре.

Соответствующий список кодов можно найти тут:
http://msdn.microsoft.com/en-us/library/windows/desktop/dd375731(v=vs.85).aspx



* Генерация файла в формате GPX с информацией о пройденным маршруте.

Соответствующая опция активируется через настройки, а также можно включить через
меню: Options -> Output -> GPS file

По умолчанию GPX файл создаётся в папке с программой.

Однако можно задать папку для сохранения GPX файлов, для этого необходимо соответствующим
образом изменить параметр Directory в ini файле:

[GPX]
Directory=C:\Мои маршруты


* Сохранение информации о текущем местоположении в файл.

В соответствующий диалог вызывается через меню: File->Save To file...
А также возможно использовать комбинацию клавиш Ctrl+Alt+S

Местоположение может быть сохранено в файл в форматах GPX, KML, TXT.



* Вывод «сырых» данных NMEA в лог файл

Для активизации данной возможности необходимо установить в единицу соответствующий параметр
AutoStart в конфигурационном в ini файле:

[RAW]
AutoStart=1

Имя файла генерируется автоматически в формате YYYY-MM-DD HH.MM.SS.NMEA

где:

yyyy-mm-dd hh.mm.ss - дата и время начала записи в файл (дата и время активации интерфейса).

По умолчанию NMEA файл создаётся в папке с программой.

Есть возможность задать папку для сохранения NMEA лог файлов, для этого необходимо соответствующим
образом изменить параметр Directory в ini файле:

[RAW]
Directory=C:\Мои маршруты

где:

Directory – Папка для сохранения лог файлов.

Для ограничения размеров лог файла возможно задать максимальное количество записей в файл:

[RAW]
MaxRecords=1000

где:

MaxRecords – максимальное количество отсчётов данных.

Если параметр MaxRecords не задан или равняется нулю, то создаётся один файл

YYYY-MM-DD HH.MM.SS.NMEA и запись продолжается пока хватит места на диске.

Если же параметр MaxRecords задан, то при начале записи создаётся файл
YYYY-MM-DD HH.MM.SS 00000001.NMEA

Затем, после достижения максимального кол-ва записей (отсчётов с данными), создаются файлы

YYYY-MM-DD HH.MM.SS 00000002.NMEA
YYYY-MM-DD HH.MM.SS 00000003.NMEA

и так далее.


===============
Версия 1.1.0.27
===============

Новые возможности:
------------------

* Поддержка вывода NMEA данных одновременно до четырех СОМ портов

Соответствующая конфигурация и параметры "дополнительных" СОМ портов устанавливаются
вручную в ini файле:

Для активации данного режима необходимо секциях [Port #2], [Port #3] и [Port #4]
параметр Number установить в ненулевое значение, соответстующее номеру СОМ порта.

Например:

[Port #2]
Number=5
;Номер COM порта куда отсылать данные (порт можно выбрать и вручную в GUI программы)
BaudRate=57600
;Скорость передачи данных через COM порт
AutoStart=0
;1 => открытие указанного выше COM порта автоматически при старте программы

А также возможно показать "дополнительныые" СОМ порты через меню:
Options -> Output -> Show extra COM ports



* Возможность посылать данные по протоколу UDP на любой адрес:порт, до черырех получателей.

В качестве получателя может быть как любой сетевой клиент, так и виртуальный порт Тиббо,
соответствующим образом сконфигурированный.

В итоге имеем не пару портов, а всего один (только со стороны навигационной программы).

По умолчанию в программе вывод в UDP отключен.
Для вывода данных по UDP (до трех получателей) нужно в конфигурационном файле прописать:

[UDP #1]
IP=127.0.0.1
Port=1015

где :

IP - адрес получателя (если на локальном компе, то естественно оставляем 127.0.0.1,
тем не менее может быть любой адрес в локальной сети или интернете).

Port - соответствующий UDP порт на стороне получателя.

Соответственно также сделать, если необходимо, настройки для [UDP #2], [UDP #3] и [UDP #4].



Измененения:
------------

* Косметические исправления в GUI.



===============
Версия 1.1.0.25
===============

Измененения:
------------

* Косметические изменения в GUI.


===============
Версия 1.1.0.22
===============

Новые возможности:
------------------

* Генерация файла в формате KML (Google Earth) с информацией о пройденным маршруте.

Соответствующая опция активируется через настройки, а также можно включить через
меню: Options -> Output -> KML file

По умолчанию KML файл создаётся в папке с программой.

Однако можно задать папку для сохранения KML файлов, для этого необходимо соответствующим
образом изменить параметр Directory в ini файле:

[KML]
Directory=C:\Мои маршруты


* Поддержка онлайн карт www.openstreetmap.org


===============
Версия 1.1.0.21
===============

Новые возможности:
------------------

* Запрет перехода системы в спящий режим и запрет отключения экрана пока активен интерфейс с GNSS сенсором.

* Игнорирование ошибок в драйвере от HUAWEI

* Возможность посылать данные по протоколу UDP на любой адрес:порт.

В качестве получателя может быть как любой сетевой клиент, так и виртуальный порт Тиббо,
соответствующим образом сконфигурированный.

В итоге имеем не пару портов, а всего один (только со стороны навигационной программы).

По умолчанию в программе вывод в UDP отключен.
Для вывода данных по UDP (до трех получателей) нужно в конфигурационном файле прописать:

[UDP #1]
IP=127.0.0.1
Port=1015

где :

IP - адрес получателя (если на локальном компе, то естественно оставляем 127.0.0.1,
тем не менее может быть любой адрес в локальной сети или интернете).

Port - соответствующий UDP порт на стороне получателя.

Соответственно также сделать, если необходимо, настройки для [UDP #2] и [UDP #3].


===============
Версия 1.1.0.14
===============

Новые возможности:
------------------

* На тулбар добавлена кнопка запуска навигационной программы
В случае, если навигационная программа не указана в настройках, то данная кнопка скрыта.


* Поддержка вывода NMEA данных одновременно до трёх СОМ портов

Соответствующая конфигурация и параметры "дополнительных" СОМ портов устанавливаются
вручную в ini файле:

Для активации данного режима необходимо секциях [Port #2] и [Port #3]
параметр Number установить в ненулевое значение, соответстующее номеру СОМ порта.

Например:

[Port #2]
Number=5
;Номер COM порта куда отсылать данные (порт можно выбрать и вручную в GUI программы)
BaudRate=57600
;Скорость передачи данных через COM порт
AutoStart=0
;1 => открытие указанного выше COM порта автоматически при старте программы

А также возможно показать "дополнительныые" СОМ порты через меню:
Options -> Output -> Show extra COM ports


* Цвет иконки в системном трее изменяется в зависимости получены ли от GPS/GLONASS
приемника актуальные данные или нет.




Исправления:
------------


Измененения:
------------



===============
Версия 1.1.0.12
===============

Общая информация:
-----------------


* Release candidate #1 (RC1)


Новые возможности:
------------------


Исправления:
------------


Измененения:
------------


 

 

Copyright © 2007 www.black-it.eu All rights reserved.
Last modified: 08.01.2019
www.000webhost.com